Fənd 11/100: Başlanğıc və bitiş tarixinə əsasən iki tarix arasında satış miqdarının cəminin tapılması - INNAB

Fənd 11/100: Başlanğıc və bitiş tarixinə əsasən iki tarix arasında satış miqdarının cəminin tapılması

D2 və E2 xanalarına yazılan başlanğıc və bitiş tarixlərinə əsasən satış miqdarlarının cəminin funksiyalar vasitəsi ilə F2 xanasına yazılması istənilməkdədir.

Cədvəldəki tarixlər:

  1. Hər zaman kiçikdən böyüyə sıralanır.
  2. Bir tarix iki və daha çox dəfə ard-arda təkrarlana bilər.

18.12.2016  18:15

 

32 Responses

  1. Samir Məmmədov dedi ki:

    “=SUM(INDIRECT(“B”&MATCH(D2;A2:A16;0)+1;TRUE):INDIRECT(“B”&MATCH(E2;A2:A16;1)+1;TRUE))”

  2. Beyrək Muxtarov dedi ki:

    =SUM(OFFSET(B2:B16,MATCH(D3,A2:A16,0)-1,0,MATCH(E3,A2:A16,1)-MATCH(D3,A2:A16,0)+1,1)) baslanğıc və bitiş tarixləri daxil olmaqla hesablayır

    • Aslan Səfərov dedi ki:

      Funksiyada D2 və E2 əvəzinə D3 və E3 yazılması texniki səhv olaraq nəzərə alınaraq
      cavabınız düzgün olaraq qeydə alınmışdır. İştirak etdiyiniz üçün təşəkkürlər.

  3. Vüsal hadiyev dedi ki:

    SUMIFS(B2:B16;A2:A16;”>=”&D2;A2:A16;”<="&E2)

  4. Elsever Sultanov dedi ki:

    =SUMIFS(B:B;A:A;”>=”&D2;A:A;”<"&E2)

    • Aslan Səfərov dedi ki:

      Funksiya yazılışı zamanı ”<=" əvəzinə ”<" yazılması texniki səhv olaraq nəzərə alınaraq
      cavabınız düzgün olaraq qeydə alınmışdır. İştirak etdiyiniz üçün təşəkkürlər.

  5. Teymur dedi ki:

    SUM(INDIRECT(ADDRESS(MATCH(D2,A1:A22,0),2,4,1),TRUE):INDIRECT(ADDRESS(MATCH(E2,A1:A22,1),2,4,1)))

  6. Elshad Nesiroglu dedi ki:

    =SUMIFS(B:B,A:A,”>=”&D1,A:A,”<="&E1)

  7. Raqub QARAZADE dedi ki:

    ikinci metod

    =SOMMEPROD(SI($E$2=A:A;1;0)));B:B)
    SI=IF
    ctrl+shift+enter (massiv) tetbiq olunmaqla

  8. Raqub QARAZADE dedi ki:

    =SOMME.SI.ENS(B2:B16;A2:A16;”>=” & D2;A2:A16;”<=" & E2)

    SOMME.SI.ENS=SUMIFS

  9. Muhammad ibn Möylud dedi ki:

    {=СУММ((A2:A16>=D2)*(A2:A16<=E2)*B2:B16)}

  10. Rafət dedi ki:

    =SUMIFS(B2:B24;A2:A24;”>=”&D2;A2:A24;”<="&E2)

  11. Orxan dedi ki:

    =SUMIFS(B2:B7,A2:A7,”>=”&D2,A2:A7,”<="&E2)

    • Aslan Səfərov dedi ki:

      B2:B7 ve A2:A7 aralığında 7 evezine 17 yazılmaması texniki səhv olaraq nəzərə alınaraq cavabınız düzgün olaraq qeydə alınmışdır.
      İştirak etdiyiniz üçün təşəkkürlər.

  12. elmar dedi ki:

    coketopla funksiyasindan istifade ederek yazmaq olar
    =sumifs(Shift!B:B;Shift!A:A;”>=”&D2(f4le sabiliyirik D2 ni);Shift!A:A;”<="&E2(f4sabitliyirik E2 ni);Shift!A:A;Shift!F2)

Bir cavab yazın

Sizin e-poçt ünvanınız dərc edilməyəcəkdir. Gərəkli sahələr * ilə işarələnmişdir