Fənd 15/100: Mətn içərisindən rəqəmlərin tapılması - INNAB

Fənd 15/100: Mətn içərisindən rəqəmlərin tapılması

A sütununa yazılan mətnlərin içərisindən rəqəmlərin tapılaraq B sütununa ard-arda yazılması üçün lazım olan funksiyanın yazılışı istənilməkdədir.

Excel faylı linki_F15

 

 

 

 

 

22.01.2017 23:00

8 Responses

  1. Raqub QARAZADE dedi ki:

    Salam,

    Bu fendin helli ile bagli cetinlik cekirem, eslinde ilk reqemlerin tapilmasi ashagidaki funksiya ile alinir, problem sonraki reqemlerin tapilmasinda cixir.
    STXT(A2;EQUIV(VRAI;ESTNUM(STXT(A2;LIGNE(INDIRECT(“1:”&NBCAR(A2)));1)*1);0);2)

    Odur ki, teklif olunan hell variantlari maraqlidir, sadece her ucu error verir, neise ince meqam var tuta bilmirem, yardimci olsaniz sevinerdim, teshekkur edirem.

  2. Muhammad ibn Möylud dedi ki:

    =СУММПРОИЗВ(ПСТР(0&A2;НАИБОЛЬШИЙ(ИНДЕКС(ЕЧИСЛО(–ПСТР(A2;СТРОКА($1:$25);1))

  3. Rafət dedi ki:

    =MID(SUMPRODUCT(–MID(“01″&A2;SMALL((ROW($1:$300)-1)*ISNUMBER(-MID(“01″&A2;ROW($1:$300);1));ROW($1:$300))+1;1);10^(300-ROW($1:$300)));2;300)

  4. Vüsal hadiyev dedi ki:

    =SUMPRODUCT(MID(0&A2;LARGE(INDEX(ISNUMBER(–MID(A2;ROW($1:$25);1))* ROW($1:$25);0);ROW($1:$25))+1;1)*10^ROW($1:$25)/10) xahis edirem mid dusturundan once –(iki xet) olmasina diqqet yetirin

Bir cavab yazın

Sizin e-poçt ünvanınız dərc edilməyəcəkdir. Gərəkli sahələr * ilə işarələnmişdir