Fənd 16/100: Təkrarlar olan siyahıdan unikal (tək) olan yeni siyahının funksiyalar vasitəsi ilə təyin edilməsi - INNAB

Fənd 16/100: Təkrarlar olan siyahıdan unikal (tək) olan yeni siyahının funksiyalar vasitəsi ilə təyin edilməsi

A sütununa yazılan təkrarlanan adlar olan siyahı əsasında C sütununda funsiyalar vasitəsi ilə təkrarlanmayan şəkildə yeni siyahının tərtib edilməsi  istənilməkdədir. C sütununa yazılan funksiyanın yazılışı istənilməkdədir.

Excel Faylı F16

 

27.01.2017  00:50

6 Responses

  1. Vüsal Hadiyev dedi ki:

    {=ЕСЛИ(ЕОШ(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($C$1:C1;$A$2:$A$17)=0;СТРОКА($A$1:$A$16));1));””;ИНДЕКС($A$2:$A$16;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($C$1:C1;$A$2:$A$17)=0;СТРОКА($A$1:$A$16));1)))}
    {=IF(ISERR(SMALL(IF(COUNTIF($C$1:C1;$A$2:$A$17)=0;ROW($A$1:$A$16));1));””;INDEX($A$2:$A$16;SMALL(IF(COUNTIF($C$1:C1;$A$2:$A$17)=0;ROW($A$1:$A$16));1)))}
    Ilk gonderdiyimde texniki sehv olub

  2. Şamo Məmmədov dedi ki:

    {=IFERROR(INDEX($A$2:$A$16; SMALL(IFERROR(1/(MATCH(A$2:A$16; A$2:A$16; 0) = (ROW(A$2:A$16)-1))*ROW(A$2:A$16); 2^32)-1; ROWS(C$2:C2))); “”)}

  3. Vusal Hadiyev dedi ki:

    {=ЕСЛИ(ЕОШ(НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($C$1:C1;$A$2:$A$16)=0;СТРОКА($A$1:$A$16));1));””;ИНДЕКС($A$2:$A$16;НАИМЕНЬШИЙ(ЕСЛИ(СЧЁТЕСЛИ($C$1:C1;$A$2:$A$16)=0;СТРОКА($A$1:$A$16));1)))}

  4. Raqub QARAZADE dedi ki:

    =INDEX($A:$A;MIN(SI(NB.SI(C$1:C1;Champ1)=0;LIGNE(Champ1);LIGNES(Champ1)+1)))
    SI= IF
    NB.SI = CountIF
    Champ1=A2:A9 xanasina istinad edir
    Ligne=Row
    Lignes = Rows

    Funksiya massiv sheklinde tetbiq olunur

  5. Konul dedi ki:

    Salam.Funksiya duzgun netice qaytarsa da, sutunda bos xanalar qalacaq.
    =IF(COUNTIF(A$2:A2;A2)=1;A2;” “)

  6. Muhammad ibn Möylud dedi ki:

    {=IFERROR(INDEX($A$2:$A$100;MATCH(SUM(COUNTIF(C$1:C6;$A$2:$A$100));COUNTIF($A$2:$A$100;”<"&$A$2:$A$100);0));"")}

Bir cavab yazın

Sizin e-poçt ünvanınız dərc edilməyəcəkdir. Gərəkli sahələr * ilə işarələnmişdir