Fənd 6/100: Exceldə unikal sayların tapılması - INNAB

Fənd 6/100: Exceldə unikal sayların tapılması

A sütununda şirkətlərin adları qeyd edilmişdir. Fikir verdinizsə bəzi şirkətlərin adı (INNAB, Saddleoft) bir neçə dəfə yazılıb. Bizə lazımdır ki, C1 xanasına unikal şirkətlərin adını yazaq. Yəni, bir şirkətin adı bir neçə dəfə təkrarlanmasına baxmayaraq onu 1 olaraq nəzərə alacağıq. Bizim nümunədə şirkətlərin unikal sayı 5-dir.

f6

Suallarınız olarsa facebook səhifəmizə və ya qrupumuza yaza bilərsiniz..

 

14 Responses

  1. VOLK ODINOCHKA dedi ki:

    =СУММ(1/СЧЁТЕСЛИ(A1:A7;A1:A7))

  2. Teymur dedi ki:

    =IF(INDEX($A$2:$A$1048547, MATCH(0, INDEX(COUNTIF($B$1:B1,$A$2:$A$1048547),0,0),0))=0,””,INDEX(COUNTIF($B$1:B1,$A$2:$A$1048547),0,0),0)))

  3. Elshad Nesiroglu dedi ki:

    =SUMPRODUCT(1/COUNTIFS(A1:A7,A1:A7))

    • innab dedi ki:

      Zəhmət olmasa, digər oxucuların da başa düşməsi üçün funksiyanın işləmə alqoritmasını izah edə bilərsinizmi?

      • Elshad Nesiroglu dedi ki:

        countifs ile siyahida olanlarin her bir xanadaki melumatin umumi siyahida nece dene oldugunu sayir, 1/countifs ise o saylarin hamisini 1-de payini hesablayir, yani netice etibari ile o xanadaki yazinin nece dene olmasindan asili olmayaraq 1-e beraber teyin edir, SUMPRODUCT ile ise neticeni cemleyirik.

  4. Beyrək dedi ki:

    {=SUM(IF(COUNTIF(A:A,A:A)>0,1/COUNTIF(A:A,A:A)))}

  5. Qarazade Raqub dedi ki:

    =SOMME(SI(FREQUENCE(EQUIV(A1:A7;A1:A7;0);EQUIV(A1:A7;A1:A7;0))>0;1))
    massive funksiya olaraq istifade olunur
    Somme = Sum
    Si=If
    Frequence=Frequency
    Equiv=Match

  6. Muhammad ibn Möylud dedi ki:

    {=SUM(1/COUNTIF(F5:F11;F5:F11))}

  7. Elsevər Sultanov dedi ki:

    {=IFERROR(IF(ROWS($C$3:C3)<=$C$1;INDEX($A$2:$A$47;SMALL(IF(FREQUENCY(IF($A$2:$A$47″”;MATCH(“~”&$A$2:$A$47;$A$2:$A$47&””;0));ROW($A$2:$A$47)-ROW($A$2)+1);ROW($A$2:$A$47)-ROW($A$2)+1);ROWS($C$3:C3)));””);””)}

Bir cavab yazın

Sizin e-poçt ünvanınız dərc edilməyəcəkdir. Gərəkli sahələr * ilə işarələnmişdir